Singapore - Voice Service Degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved and the service is once again operational.
Difficulties reaching our Voice service and failing calls could have been observed during the below-specified timeframe.

Start (UTC): 18 June 2026 12:37
End (UTC): 18 June 2026 13:05
Impact: Voice calls processing disruption
Posted Jun 18, 2026 - 13:11 UTC

Investigating

We are currently experiencing issues with our Voice Service on Singapore data center. You may experience issues with calls failing.
Our Team is already investigating and more updates will follow.
Posted Jun 18, 2026 - 13:01 UTC
This incident affected: Voice (Singapore).