The Voice service degradation has been resolved. After monitoring and verification, our dedicated team confirms that all services are operating normally without any remaining issues.
Start (UTC): 19 March 2026 21:11 End (UTC): 20 March 2026 00:22
Impact: Customers may have experienced connectivity issues and service degradation.
Thank you for your understanding and patience.
Posted Mar 20, 2026 - 01:03 UTC
Update
Our dedicated team is still working on implementing a fix. We will continue to monitor the situation and provide updates.
Posted Mar 19, 2026 - 23:35 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 19, 2026 - 22:49 UTC
Investigating
We are currently experiencing issues at our South Africa data center. You may experience connectivity issues and service degradation. Our team is inspecting the issue, and more details will follow in the next update.