Multiple Locations - WhatsApp Traffic Processing Degradation

Incident Report for Infobip

Resolved

The issue has been successfully resolved and the service is once again operational.

Start (UTC): 18 June 2026 07:29
End (UTC): 19 June 2026 11:37
Impact: You might have experienced delays in processing of WhatsApp traffic
Posted Jun 19, 2026 - 12:50 UTC

Update

Our teams are continuously monitoring the situation to ensure it is fully resolved.
Posted Jun 19, 2026 - 10:26 UTC

Update

Our team is actively monitoring the situation to ensure that the issue has been completely resolved and does not reoccur.
Posted Jun 19, 2026 - 04:55 UTC

Update

Our team is continuing to monitor the situation to confirm it is completely resolved.
Posted Jun 19, 2026 - 00:38 UTC

Update

The delays and processing issues appear to have been resolved. Our teams are continuing to monitor the situation to ensure it is fully resolved.
Posted Jun 18, 2026 - 19:53 UTC

Update

Our dedicated team has deployed a fix and remains actively engaged in monitoring the situation.
Posted Jun 18, 2026 - 14:38 UTC

Monitoring

Our dedicated team has deployed a fix and is currently monitoring the situation.
Posted Jun 18, 2026 - 12:21 UTC

Update

We are continuing to work on a fix for this issue and our engineering team is actively investigating. We will provide further updates as soon as new information becomes available.
Posted Jun 18, 2026 - 09:37 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2026 - 08:39 UTC

Update

Our engineering team is actively investigating the issue and we will share additional updates as soon as new information becomes available.
Posted Jun 18, 2026 - 08:10 UTC

Update

We are continuing to investigate this issue.
Posted Jun 18, 2026 - 07:45 UTC

Investigating

We are currently encountering delays in processing of WhatsApp traffic.
Our dedicated team is already checking this and more updates will follow.
Posted Jun 18, 2026 - 07:45 UTC
This incident affected: WhatsApp Business (Global (Europe), India).